Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Unable to connect to WiFi



  • Bump.


  • Global Moderator

    @six-string Can you post your /etc/network/interface and the /etc/wpa_supplicant/wpa_supplicant.conf files ? Remove and passwords from them, if present.

    Have you tried the manual setup steps from the Wifi docs ? You can enter your SSID/Pass on the PC to make sure they're correct.



  • @mitu I've tried every method on that page, short of the Raspbian Stretch (not sure if that's applicable to my setup, I'm not a Linux guy). I tried the wifikeyfile.txt method and it told me the file was not found. I can try that one again, though. UPDATE: I just tried this again, and I get the message "No /boot/wifikeyfile.txt found"

    /etc/network/interface:

    auto lo
    
    iface lo inet loopback
    iface eth0 inet dhcp
    
    allow-hotplug wlan0
    auto wlan0
    iface wlan0 inet dhcp
       wpa-ssid ""
       wpa-psk ""
    

    Note that I had to enter this, as when starting from a fresh image, the interface file is empty.

    wpa_supplicant.conf:

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    

  • Global Moderator

    @six-string said in Unable to connect to WiFi:

    I've tried every method on that page, short of the Raspbian Stretch

    That may be the problem. On my system

    • there is no /etc/network/interfaces file
    • the /etc/wpa_supplicant/wpa_supplicant.conf contains
    country=DE
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    
    # RETROPIE CONFIG START
    network={
        ssid="MySSID"
        psk="<password has here>"
    }
    # RETROPIE CONFIG END
    

    I didn't do any manual configuration, right after I flashed the image - and before booting the Pi - I added a file on the boot partition with the right settings as described in the docs. On 1st boot, the wifi was automatically configured and didn't have to do any other configuration.



  • @mitu Just did a fresh write, and followed the Raspbian Stretch method. Upon entering Raspi-config, I got a message that my Wifi country was not set in wpa_supplicant (which is false, I had it in the very top just like you/the docs show). I set the country, and it still showed I was not on the network. I just tried entering the wifi credentials and nothing.

    I just checked my wpa_supplicant.conf and it is looks like this:

    ctrl_interface=DIR=var/run/wpa_supplicant GROUP=netdev
    update_config=1
    country=US
    # RETROPIE CONFIG START
    network={
                 ssid="<SSID>"
                 psk="<psk>"
                 scan_ssid=1
    }
    # RETROPIE CONFIG END
    

    Note that this is not how I had the file when I set it up from my PC.


  • Global Moderator

    @six-string If you configured the WiFi as the docs mentioned (keyboardless Raspbian Stretch), then you don't need to use raspi-config anymore. The country is mandatory only for the the 3B+ model, but regardless the Wifi should work with the your config file.

    If this still doesn't work, then the problem is somewhere else. I'd ask for a dmesg output, but without a network connection it would be hard to get that out and put it on pastebin.com.



  • @mitu I ran dmesg, and I noticed a couple lines which repeated and seems like it might be relevant:

    brcmfmac: power management disabled
    

    and

    IPv6: ADDRCONF (NETDEV_UP): eth0: link is not ready
    

    Other than that, it's mostly X initialized, New USB device found, Y registered, etc

    There is also a Logitech device it's unable to retrieve the name for, which I assume is my keyboard, but I couldn't imagine that being relevant.


  • Global Moderator

    @six-string I have no idea why it's not working. Since you're still at the beginning, you could try flashing the full Raspbian image (www.raspbian.org) to have an easier set of tools to configure Wifi and give it a shot this way. If it works (the WiFi), then you can install RetroPie on top of Rasbian with the manual installation method and get your system fully working.



  • @mitu Well... just installed Raspbian. Still can't connect to network.

    Guess I'll look into troubleshooting that. Thanks.



  • @six-string said in Unable to connect to WiFi:

    @mitu Well... just installed Raspbian. Still can't connect to network.

    Guess I'll look into troubleshooting that. Thanks.

    This is stupid but I found solution. You need to connect an RJ45 (ethernet) cable to rpi port. Now you can run raspi-config without wpa-supplicant error and There was an error running option N2 Wi-fi.. Then can you now set ssid and password (now reboot or not) and wifi will works correctly.

    When this wifi works correctly bluetooth too works good. When I had problem (like you) with wifi my bluetooth was non stop disconnecting.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.