Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

SOLVED - Help! PCSX-ReArmed stopped working!



  • I'll keep it brief. I built a Freeplay Zero handheld, using RetroPie 4.3.8 as the base image. Everything worked perfect. Then, the guys over at Freeplay Tech released and update for the LCD screen driver that improves frame rate, so I wiped the SD card and installed their RetroPie 4.4 image. The driver did not work, and PCSX-ReArmed would not work either.

    I wiped the SD card again, and installed Freeplay Tech's 4.3.8 image. However, pcsx still isn't working. When I select a game, the screen either stays black with no sound or has yellow lines throughout. At first I thought retroarch was scaling the display too high for the LCD screen to handle, but I've set my video mode to 640x480 and framebuffer to 320x240. I've made sure my BIOS is in the BIOS folder as well. Is there anything I can try to get this to work? The libretro core works but the non libretro core is the only option to play PSX on a Pi Zero full speed! :/

    EDIT: Got it working! I'm not sure why, but it seems that pcsx-rearmed bases its resolution off whatever the framebuffer is set to in /boot/config.txt and NEVER CHANGES, even if the values for frame buffer change. Before installing pcsx-rearmed, I changed my frame buffer to 640x480. Installed the emulator and got it set up with this guide, then changed it back to 320x240 and all is good again. :)



  • Have a small update. I have verified that HDMI output works. Something is going on with how the LCD screen on my Freeplay Zero handles the resolution of the emulator. I wanted to see if I could change it in the emulator, but there are no options for resolution. :/



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.