Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Changed ISP and Router now Retropie obtains IP address but cannot access internet



  • Hi There,

    I am using an RPi3 (older model) and Retropie 4.2. When I originally installed I was using Virgin Media as my ISP and their router. I have now moved and have changed ISP to Sky and changed to their router. When I configure wifi my Pi obtains an IP address however cannot connect to the internet (i.e. connect to GitHub to update setup script). If I ping www.bbc.co.uk it does not work but pinging 8.8.8.8 seems to yield results. Can anybody help me?! Really don't want to go through a fresh install of Retropie.

    Many thanks!!



  • @mrscruff300 Does your router use MAC filtering? What kind of wifi security setup wpa, wpa2, etc?

    8.8.8.8 sounds like you have google dns setup on your router?



  • Hi HurricaneFan,

    Thanks very much for coming back to me. I’ve had a look at the router settings, I can’t see anything in relation to Mac filtering. The security is WPA2. All my other wireless/wired devices work perfectly well with my router.

    I should also add that I see exactly the same behaviour if I plug in an Ethernet cable, I obtain an IP address but no access to the internet!

    I’m wondering if it is anything to do with the network configuration in retropie as it has only happened since I moved and changed router and isp.

    Cheers!


  • Global Moderator

    @mrscruff300 If you get your IP address via DHCP, then check if your router provides the DNS server correctly. Do you have any other software installed on the Pi that might interfere with the network settings ? You didn't provide any of the information requested in https://retropie.org.uk/forum/topic/3/read-this-first, so it's kind of a guessing game at this point.



  • Hi mitu,

    Many thanks for your message :)! Apologies, please see info below:

    Pi Model or other hardware: RPi 3 (old model)
    Power Supply used: official RPi power supply 2.5A version
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.2
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: USB mouse, USB keyboard, USB memory stuck
    Controller used: PS3
    Error messages received: If I try to ping www.google.co.uk I get unknown host error (same with any external web address.

    I don’t have any other software installed other than Retropie. I don’t know anything about routers, they have always just worked, didn’t change any of the automatic settings on the Sky router. I’m not sure how my devices obtain their IP addresses, if there a way for me to find out? Also don’t know how to check whether the router is providing the correct DNS. As I mentioned I have no issues with any other devices joining my network. I did see on other websites to try pinging 8.8.8.8 and this is the only thing that has yielded a ping result in command line with all packets sent and received. I don’t know if that means anything. Was wondering if something was wrong with my /etc/resolv.conf file :/?

    Cheers!


  • Global Moderator

    Normally the network settings - including the IP address and DNS server - are given by the router to the device asking for configurations. The PI should do the same, but for some reason it does not.
    Can you provide the contents of the /etc/network/interfaces and /etc/resolv.conf ?



  • Ok guys, so feeling a bit stupid but I think it is resolved! I remembered that a long time ago I manually used openvpn and when setting up nordvpn told me to amend the contents of /etc/resolv.conf to their servers and fix it with:

    sudo chattr -i /etc/resolv.conf

    Googled around a bit and it seems nordvpn have changed their server addresses, guess the old ones were deactivated rendering my internet useless!

    Opened up /etc/resolv.conf by typing:

    sudo chattr -i /etc/resolv.conf

    Rebooted and the server address in /etc/resolv.conf
    Is now reflected my routers address and all seems to be working again :)!

    If I ever wanted to use openvpn again would I need to reset the server DNS addresses to the new nordvpn servers again?

    Cheers!



  • This post is deleted!


  • I m sorry to say ,but you need to go through a fresh install of retropie. this happened with me and i tried all different kind of ways but at the end i had to take the trouble.
    All the best.



  • it may be the problem of your router login panel ..you should reboot the router and then try again..



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.