Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Custom viewport problem retroarch 1.7.5



  • @udb23 yeah, I know... They did. They must have added another resolution setting but not at the end of the list.

    You can check it yourself by changing the setting in the GUI and then verifying the selection in the .cfg file.

    I'd have to install 1.7.4 to confirm when the change took place since I went from 1.7.3 to 1.7.5.

    There's currently 24 aspect ratio options in 1.7.5. I imagine there used to be 23 with "custom" previously being the last on the list as "22"

    Was:
    0=.....
    1= ...
    2= ...
    ....
    19=Config
    20=1:1 PAR
    21=core selected
    22=Custom

    Now:

    "23"=custom and it's option 24.



  • Ok, I confirmed. The change took place with 1.7.4.

    On that version they added a new aspect ratio "21:9", and this was added as the 5th option between "16:15" and "1:1" thus pushing custom from "22 to 23"

    I suppose most retroarch users would just change to custom in the GUI after updating if needed and not think anything of it.

    Anyway, I updated the docs wiki. Hopefully someone will confirm my findings and make my change live so new users don't bang their heads against the wall using "22" for custom.


  • administrators

    @keltron3030 Thanks. I will update the code for the config editor.



  • @keltron3030 Thanks for confirming.
    I therefore need to check impacted overlays in my Repo.. For sure some console overlay cfgs in there must be changed (e.g. atari2600, GBA).

    Not sure if aspect ratio is also used by @meleu overlay install script.



  • @udb23 It's been a while since I put my eyes on that code, but IIRC it only handles file paths. Then I think this change in RetroArch doesn't impact anything on my script.

    But please, ping me if you find some problem. ;)



  • @meleu Ok! Thanks



  • Has this been changed again? I don't think so, because everything with a custom overlay works for me.

    But everything that doesn't have a defined custom overlay is showing up black still with sound and retroarch overlays. I'm confused.

    Edit: RetroArch.cfg included.

    Edit 2: Changing my \arcade\retroarch.cfg aspect ratio to 22 from 23 fixed it. Still kind of begs the question... should it be 22 again?



  • @Keltron3030 Confirmed. It works on 23. I was beginning to think I had completely misunderstood the order of precedence for config. Whew! Thanks



  • Ah this totally makes sense! I was confused last time I was setting up a 240p setup and “22” wasn’t making my resolutions work on my new setup.



  • Hmm... I recently updated as well and am seeing that my overlays now stretch over onto the game display when they didn't used to. But I am not using the aspect ratio indexing at all.

    My Frogger cfg for example:

    input_overlay = /opt/retropie/emulators/retroarch/overlays/arcade-bezels/Final_Arcade_Frogger.cfg
    input_overlay_enable = true
    input_overlay_opacity = 0.900000
    input_overlay_scale = 1.000000
    
    video_shader_enable = "true"
    video_shader = "~/.config/retroarch/shaders/crt-pi-curvature-vertical.glslp"
    


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.