Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

video snaps and core help



  • Hello,
    I managed to get emaulation station working with some nes and snes roms and I have chosen a theme that supports video snaps but I cannot figure out how to get them working or when looking through "Docs" find out how to use them. I downloaded .mp4 files and put them in the same folder as the roms and also crated a snaps folder with the roms and put them there but they still don't show up in say "space oddity" theme.

    Also, I'm using a rpi 3b+ and I read for nes that I should change to lr-nestopia , I'm wondering how do I change to that from the default one I've been using? All I've managed to figure out is how to configure the controller and load roms and snaps.

    Thanks.


  • Global Moderator

    The core has nothing to do with the videos not being shown, the front-end (Emulationstation) is responsible for that. Emulationstation does not automatically try to detect videos/images for the ROMs it has in the list, they are usually added in the gamelist.xml by the scraper.
    There is an option in Emulationstation (Use Local Art, disabled by default), which makes Emulationstation look for artwork (video/images) in the ROM path - it tries to read <romname>-video.mp4 and <romname>-image.png/jpg. You should name your videos accordingly and re-try.

    As for how to change the emulator core, you use the Runcommand launch menu to choose it and you can set it as default for all NES games or for just one game.



  • @mitu said in video snaps and core help:

    The core has nothing to do with the videos not being shown, the front-end (Emulationstation) is responsible for that. Emulationstation does not automatically try to detect videos/images for the ROMs it has in the list, they are usually added in the gamelist.xml by the scraper.
    There is an option in Emulationstation (Use Local Art, disabled by default), which makes Emulationstation look for artwork (video/images) in the ROM path - it tries to read <romname>-video.mp4 and <romname>-image.png/jpg. You should name your videos accordingly and re-try.

    As for how to change the emulator core, you use the Runcommand launch menu to choose it and you can set it as default for all NES games or for just one game.

    Right I was posting about 2 separate issues sorry.
    How do you enable Use Local Art? I have my videos named "romname.mp4" so I will rename them to "romname-video.mp4"

    Also, so that is what that little pop up box is for, not sure how I missed that in the Docs. What does this part mean: "(the bottom face button is recommended as to not accidentally change anything) " ?


  • Global Moderator

    @merkury187 said in video snaps and core help:

    How do you enable Use Local Art? I have my videos named "romname.mp4" so I will rename them to "romname-video.mp4"

    Open the Emulationstation menu with Start and try looking through the available options - I think it's in the UI sub-menu (?).

    Also, so that is what that little pop up box is for, not sure how I missed that in the Docs. What does this part mean: "(the bottom face button is recommended as to not accidentally change anything) " ?

    Use the A or B buttons.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.