Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

How-to guide: Recording Live Gameplay in RetroPie’s RetroArch Emulators Natively on the Raspberry Pi (and Twitch streaming)



  • @selsine Cheers selsine, that's great to hear. I've responded to your comments on my blog as well (sorry for the delay in replying). Thanks



  • I've still not got around to revisiting the issue of getting Streaming to Twitch working, however this weekend a user posted a couple of links in the comments section of my blog post for the guide; in their linked article they use ffmpeg to stream from the Pi, albeit not from within RetroArch. I feel sure there's a way to combine all the available information and get this working!



  • @RetroResolution I actually got Twitch streaming working today and wrote a quick blog post about it: How To Live Stream To Twitch from a RetroPie

    I ended up using the following FFmpeg settings, 'libmp3lame' caused a bus error and would crash so I switched to 'aac':

    vcodec = libx264
    acodec = libfdk_aac
    pix_fmt = yuv420p
    threads = 2
    scale_factor = 1
    format = flv
     
    video_preset = ultrafast
    video_profile = baseline
    video_tune = animation
    video_level = 1.2
     
    sample_rate = 44100
    audio_preset = aac_he_v2
    

    I'm still trying to figure out the FFmpeg settings because what is available in the config file doesn't seem to match what the FFmpeg documentation has 100%. I'm assuming that some translation is happening but I'm not sure.

    Maybe someone who knows FFmpeg really well can point us in the right direction.

    If it's up my Twitch stream is here:



  • @selsine said in How-to guide: Recording Live Gameplay in RetroPie’s RetroArch Emulators Natively on the Raspberry Pi (and Twitch streaming):

    The following config settings seem to be working much better than my previous settings:

    vcodec = libx264
    acodec = libfdk_aac
    pix_fmt = yuv420p
    threads = 2
    scale_factor = 1
    format = flv
    
    video_preset = ultrafast
    video_profile = main
    video_tune = animation
    video_bufsize = 512k
    video_minrate = 512k
    video_maxrate = 512k
    video_r = 60
    video_g = 120
    video_keyint_min = 60
    
    sample_rate = 44100
    audio_preset = aac_he_v2
    audio_global_quality = 1
    


  • How about Youtube streaming? Is it possible?



  • @Rion said in How-to guide: Recording Live Gameplay in RetroPie’s RetroArch Emulators Natively on the Raspberry Pi (and Twitch streaming):

    How about Youtube streaming? Is it possible?

    Yup, I wrote up a quick guide: How To Live Stream To YouTube from a RetroPie

    It's the same thing as streaming to twitch except you use the YouTube RTMP URL and your YouTube stream key.

    I've noticed that the performance on the YouTube live stream isn't as good as the twitch stream, so the FFmpeg settings probably need to be tweaked.



  • Great work on the guide, thank you very much! Using scale_factor on the cfg to double the resolution really ramps up the CPU usage to make it impossible! I found a way to make it work and failed to get a recording thus far though.

    Raspberry Pi 3 has an integrated hardware encoder, dubbed h264_omx and to use it you need to compile ffmpeg with these added:

    –enable-omx
    –enable-omx-rpi
    –enable-mmal

    I compiled FFMPEG with these, but when I choose h264_omx as my encoder it results in an empty recording. What am I doing wrong?

    Also, most encoders and formats do not work, which is really super weird.

    By the way, if this works as intended, the hardware encoder can do live transcoded 720p livestreams or recordings with no sweat. I've seen a person use a raspberry pi 2 as a transcoding PC through nginx-rtmp to stream to Twitch.



  • Hi all,

    I've managed to get gameplay recording working for PSX after following the great guides BUT I have hit a bit of a snag. Some PSX games record OK at first when you launch it so the intro, menus etc record OK, but as soon as you get in to the actual game the screen goes black and I can only hear sound. What have I done wrong?

    I tested 3 PSX games:

    Retropie 4.1
    Retroarch 1.3.6

    Alexi Lalas International Soccer [See video below]

    Lone Soldier

    Doom (worked OK with no issues ??)

    These are both using my config.cfg file which is as follows:

    format = matroska
    threads = 3
    vcodec = libx264rgb
    video_preset = ultrafast
    video_tune = animation
    pix_fmt = bgr24
    video_qp = 0
    acodec = flac

    Could it be an NTSC/PAL related problem?

    Any ideas?

    Thanks!



  • @RetroResolution , hi!

    First of all, thank you for the rich tutorial! Besides I haven't accomplished to start the recordings, I think I will get there.

    I am new to Retropie, but I could understand almost everything you told about this process.

    I have a Raspberry Pi 3 running Retropie (fresh 4.1 installation) . I Did not install over an existing Raspbian, but instead, I've burned a Retropie 4.1.
    RetroArch version is 1.3.6.

    I have succeeded the FFmpeg installation (used your script).

    But, on the step:

    "Rebuilding RetroArch to Enable FFmpeg Recording"

    after following your instructions with the script:

    #remove the config that disables ffmpeg on the RPI
    sed -i "s/--disable-ffmpeg//" scriptmodules/emulators/retroarch.sh
    #build new retroarch from source
    sudo ./retropie_packages.sh retroarch
    #put the file back how it was
    git checkout scriptmodules/emulators/retroarch.sh

    I 've got this:

    0_1485018636745_out1.png

    I've tried to find the ffmpeg driver on settings menu ( I'm using Retroach 1.3.6)
    but it still shows 'null'.

    Well, I've read your new considerations about "OBTAIN AND BUILD SPECIFIC VERSION OF RETROARCH TO ENABLE FFMPEG RECORDING".

    I repeated all command line procedures as suggested by you and in the end I've got to this:

    0_1484960558729_out2.png
    What am I doing wrong? Sorry for the long post, but I believe this is a feedback to you, as new releases come always with issues!

    Thank you!

    Filipe



  • I compiled FFMPEG with these, but when I choose h264_omx as my encoder it results in an empty recording. What am I doing wrong?

    Does anything show up in your /dev/shm/runcommand.log logfile when you try to use h264_omx?



  • Hey all!

    I just want to say that I made it! I have flawless videos recordings from SNES!

    But, as a feedback, I will put something I realized after trying different things.

    First, as I posted before, I was trying to follow all procedures as described by the rich tutorial written by @RetroResolution - Recording Live Gameplay in RetroPie’s RetroArch Emulators Natively on the Raspberry Pi .

    I was using a fresh Retropie 4.1 installation. As I told on the previous post, I've failed to rebuild Retroarch.

    So, I decided to install the last version of Raspbian Jessie Light (without Pixel).

    Then, I first installed FFmpeg using the All in One Script ( thanks again, @RetroResolution!) and tested it, confirming it was working properly.

    I have manually installed and configured Retropie and, after using the few steps first described in the tutorial:

    "OBTAIN AND BUILD SPECIFIC VERSION OF RETROARCH TO ENABLE FFMPEG RECORDING".

    I still could not succeed!!!

    Well, I got really intrigued with this persistent issue: fail to apply pach when running retroarch.sh during the rebuilding procedure...

    So, as a last try, I went to the little tutorial posted by @selsine (thanks for that: How To Record A GamePlay Video From A RetroPie) because you put something important there:

    "And finally execute it, but NOT as root:

    $ . /home/pi/tools/build-retroarch-with-ffmpeg.sh"

    And suddenly, Retroarch is rebuilt!

    Well, I don't know if it has something to do with the permissions (ownership) but it did run.

    Now, I am just testing some configurations, but it seem to run really smooth to me!

    To conclude:

    I suspect it does not work using retropie image from the website. If you manually install, it works! Please, correct me if I'm wrong.

    And, many thanks to you guys for the amazing information you share!



  • @budegarower That's great. I'm pretty sure that you have to run it not as root. I think I remember running into the same issues when I was setting everything up.



  • got it recording but have no audio output to my tv the recording has audio though using hdmi



  • What do we need to do to make this come in standard release? I'd love to see this built in.



  • @selsine no, only the retroarch command is shown, e.g.:

    pi@retropie:~ $ cat /dev/shm/runcommand.log
    Parameters:
    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-fbalpha/fbalpha_libretro.so --record /mnt/retropie/recording_$(date +%Y-%m-%d-%H%M%S).mkv --recordconfig /home/pi/RetroPie/recording/config.cfg --config /opt/retropie/configs/neogeo/retroarch.cfg "/home/pi/RetroPie/roms/neogeo/mspacmnf.zip" --appendconfig /dev/shm/retroarch.cfg
    pi@retropie:~ $



  • Hello everybody,
    thanks for your fantastic guide @RetroResolution , I got it working with almost no problems.

    However what I am experiencing with my Pi model 3 / 10,000kbit upload bandwidth (wlan though) is that my emulator stutters/lags slightly to badly in intervals of 20 minutes or so, and the stream was cut off completely after 2 hours. Cpu temperature/load and memory load were all good. At first I thought it might be related to me not using a real storage instead of the SD card but the swap file is always size 0 (using YARMan Web to check). I looked for some sort of logs but couldn't find anything relevant (runcommand.log has no errors). I already tried increasing the buffer size but that didn't do anything good.

    Does anyone have an idea what this could be?

    Btw I also found a -hwaccel option in ffmpeg which is disabled by default although there would be devices available. Would that be advisable? Couldn't figure out how to correctly use this though ("stream specifier"?)

    edit: the following settings work for me:

    video_bufsize = 4096k
    video_minrate = 384k
    video_maxrate = 384k



  • Hey All,

    Here is the issue I am having.

    RetroPie 4.2
    RetroArch 1.6 (I believe. Not at home.)

    I followed the guide. No connection to Twitch. Here is the runcommand.log

    Parameters: 
    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-snes9x2010/snes9x2010_libretro.so --config /opt/retropie/configs/snes/retroarch.cfg --record rtmp://live-jfk.
    /live_102953334_OpSc8wBkhEdG9gKikpa80ZYrNBHpG5 --recordconfig /home/pi/RetroPie/recording/twitch.cfg "/home/pi/RetroPie/roms/snes/Aladdin (USA).zip" --appendconfig /dev/shm/retroarch.cfg RetroArch [INFO] :: Loading dynamic libretro core from: "/opt/retropie/libretrocores/lr-snes9x2010/snes9x2010_libretro.so" RetroArch [INFO] :: [overrides] no core-specific overrides found at /home/pi/.config/retroarch/config/Snes9x 2010/Snes9x 2010.cfg. RetroArch [INFO] :: [overrides] no game-specific overrides found at /home/pi/.config/retroarch/config/Snes9x 2010/Aladdin (USA).cfg. RetroArch [INFO] :: Shaders: preset directory: /home/pi/.config/retroarch/shaders/presets RetroArch [INFO] :: Shaders: no game-specific preset found at /home/pi/.config/retroarch/shaders/presets/Snes9x 2010/Aladdin (USA).cgp. RetroArch [INFO] :: Shaders: no game-specific preset found at /home/pi/.config/retroarch/shaders/presets/Snes9x 2010/Aladdin (USA).glslp. RetroArch [INFO] :: Shaders: no core-specific preset found at /home/pi/.config/retroarch/shaders/presets/Snes9x 2010/Snes9x 2010.cgp. RetroArch [INFO] :: Shaders: no core-specific preset found at /home/pi/.config/retroarch/shaders/presets/Snes9x 2010/Snes9x 2010.glslp. RetroArch [INFO] :: Environ SET_VARIABLES. RetroArch [INFO] :: Environ SET_CONTROLLER_INFO. RetroArch [INFO] :: Controller port: 1 RetroArch [INFO] :: SNES Joypad (ID: 1) RetroArch [INFO] :: SNES Mouse (ID: 2) RetroArch [INFO] :: RetroPad (ID: 1) RetroArch [INFO] :: Controller port: 2 RetroArch [INFO] :: SNES Joypad (ID: 1) RetroArch [INFO] :: SNES Mouse (ID: 2) RetroArch [INFO] :: Multitap (ID: 257) RetroArch [INFO] :: SuperScope (ID: 260) RetroArch [INFO] :: Justifier (ID: 516) RetroArch [INFO] :: Justifiers (ID: 772) RetroArch [INFO] :: RetroPad (ID: 1) RetroArch [INFO] :: Remaps: remap directory: /opt/retropie/configs/snes/ RetroArch [INFO] :: Remaps: no game-specific remap found at /opt/retropie/configs/snes/Snes9x 2010/Aladdin (USA).rmp. RetroArch [INFO] :: Remaps: no core-specific remap found at /opt/retropie/configs/snes/Snes9x 2010/Snes9x 2010.rmp. RetroArch [INFO] :: Redirecting save file to "/home/pi/RetroPie/roms/snes/Aladdin (USA).srm". RetroArch [INFO] :: Environ GET_OVERSCAN: 0 RetroArch [INFO] :: Environ GET_LOG_INTERFACE. RetroArch [INFO] :: Environ SET_SUPPORT_ACHIEVEMENTS: yes. RetroArch [INFO] :: Environ SET_PIXEL_FORMAT: RGB565. RetroArch [libretro INFO] :: Frontend supports RGB565 - will use that instead of XRGB1555. RetroArch [INFO] :: Environ PERFORMANCE_LEVEL: 7. RetroArch [INFO] :: Loading content file: /tmp/retroarch/Aladdin (USA).sfc. RetroArch [INFO] :: Did not find a valid content patch. RetroArch [INFO] :: CRC32: 0x124d8e4d . RetroArch [INFO] :: Environ SET_INPUT_DESCRIPTORS: RetroArch [INFO] :: RetroPad, User 1, Button "B (bottom)" => "B" RetroArch [INFO] :: RetroPad, User 1, Button "Y (left)" => "Y" RetroArch [INFO] :: RetroPad, User 1, Button "Select" => "Select" RetroArch [INFO] :: RetroPad, User 1, Button "Start" => "Start" RetroArch [INFO] :: RetroPad, User 1, Button "D-Pad Up" => "D-Pad Up" RetroArch [INFO] :: RetroPad, User 1, Button "D-Pad Down" => "D-Pad Down" RetroArch [INFO] :: RetroPad, User 1, Button "D-Pad Left" => "D-Pad Left" RetroArch [INFO] :: RetroPad, User 1, Button "D-Pad Right" => "D-Pad Right" RetroArch [INFO] :: RetroPad, User 1, Button "A (right)" => "A" RetroArch [INFO] :: RetroPad, User 1, Button "X (up)" => "X" RetroArch [INFO] :: RetroPad, User 1, Button "L" => "L" RetroArch [INFO] :: RetroPad, User 1, Button "R" => "R" RetroArch [INFO] :: RetroPad, User 2, Button "B (bottom)" => "B" RetroArch [INFO] :: RetroPad, User 2, Button "Y (left)" => "Y" RetroArch [INFO] :: RetroPad, User 2, Button "Select" => "Select" RetroArch [INFO] :: RetroPad, User 2, Button "Start" => "Start" RetroArch [INFO] :: RetroPad, User 2, Button "D-Pad Up" => "D-Pad Up" RetroArch [INFO] :: RetroPad, User 2, Button "D-Pad Down" => "D-Pad Down" RetroArch [INFO] :: RetroPad, User 2, Button "D-Pad Left" => "D-Pad Left" RetroArch [INFO] :: RetroPad, User 2, Button "D-Pad Right" => "D-Pad Right" RetroArch [INFO] :: RetroPad, User 2, Button "A (right)" => "A" RetroArch [INFO] :: RetroPad, User 2, Button "X (up)" => "X" RetroArch [INFO] :: RetroPad, User 2, Button "L" => "L" RetroArch [INFO] :: RetroPad, User 2, Button "R" => "R" RetroArch [INFO] :: RetroPad, User 3, Button "B (bottom)" => "B" RetroArch [INFO] :: RetroPad, User 3, Button "Y (left)" => "Y" RetroArch [INFO] :: RetroPad, User 3, Button "Select" => "Select" RetroArch [INFO] :: RetroPad, User 3, Button "Start" => "Start" RetroArch [INFO] :: RetroPad, User 3, Button "D-Pad Up" => "D-Pad Up" RetroArch [INFO] :: RetroPad, User 3, Button "D-Pad Down" => "D-Pad Down" RetroArch [INFO] :: RetroPad, User 3, Button "D-Pad Left" => "D-Pad Left" RetroArch [INFO] :: RetroPad, User 3, Button "D-Pad Right" => "D-Pad Right" RetroArch [INFO] :: RetroPad, User 3, Button "A (right)" => "A" RetroArch [INFO] :: RetroPad, User 3, Button "X (up)" => "X" RetroArch [INFO] :: RetroPad, User 3, Button "L" => "L" RetroArch [INFO] :: RetroPad, User 3, Button "R" => "R" RetroArch [INFO] :: RetroPad, User 4, Button "B (bottom)" => "B" RetroArch [INFO] :: RetroPad, User 4, Button "Y (left)" => "Y" RetroArch [INFO] :: RetroPad, User 4, Button "Select" => "Select" RetroArch [INFO] :: RetroPad, User 4, Button "Start" => "Start" RetroArch [INFO] :: RetroPad, User 4, Button "D-Pad Up" => "D-Pad Up" RetroArch [INFO] :: RetroPad, User 4, Button "D-Pad Down" => "D-Pad Down" RetroArch [INFO] :: RetroPad, User 4, Button "D-Pad Left" => "D-Pad Left" RetroArch [INFO] :: RetroPad, User 4, Button "D-Pad Right" => "D-Pad Right" RetroArch [INFO] :: RetroPad, User 4, Button "A (right)" => "A" RetroArch [INFO] :: RetroPad, User 4, Button "X (up)" => "X" RetroArch [INFO] :: RetroPad, User 4, Button "L" => "L" RetroArch [INFO] :: RetroPad, User 4, Button "R" => "R" RetroArch [INFO] :: RetroPad, User 5, Button "B (bottom)" => "B" RetroArch [INFO] :: RetroPad, User 5, Button "Y (left)" => "Y" RetroArch [INFO] :: RetroPad, User 5, Button "Select" => "Select" RetroArch [INFO] :: RetroPad, User 5, Button "Start" => "Start" RetroArch [INFO] :: RetroPad, User 5, Button "D-Pad Up" => "D-Pad Up" RetroArch [INFO] :: RetroPad, User 5, Button "D-Pad Down" => "D-Pad Down" RetroArch [INFO] :: RetroPad, User 5, Button "D-Pad Left" => "D-Pad Left" RetroArch [INFO] :: RetroPad, User 5, Button "D-Pad Right" => "D-Pad Right" RetroArch [INFO] :: RetroPad, User 5, Button "A (right)" => "A" RetroArch [INFO] :: RetroPad, User 5, Button "X (up)" => "X" RetroArch [INFO] :: RetroPad, User 5, Button "L" => "L" RetroArch [INFO] :: RetroPad, User 5, Button "R" => "R" RetroArch [libretro INFO] :: No ROM file header found. PPU.RenderSub = 0 PPU.FullClipping = 1 Settings.Transparency = 1 Settings.SpeedhackGameID = 0 PPU.SFXSpeedupHack = 0 coldata_update_screen = 1 RetroArch [libretro INFO] :: "ALADDIN" [checksum ok] LoROM, 16Mbits, ROM, NTSC, SRAM:0Kbits, ID:__, CRC32:124D8E4D RetroArch [INFO] :: Environ GET_VARIABLE snes9x_next_overclock: RetroArch [INFO] :: Disabled(10MHz) RetroArch [INFO] :: Environ SET_MEMORY_MAPS. RetroArch [INFO] :: ndx flags ptr offset start select disconn len addrspace RetroArch [INFO] :: Skipping SRAM load.. RetroArch [INFO] :: CHEEVOS system RAM: 0x2cd5d30 131072 RetroArch [INFO] :: CHEEVOS save RAM: 0x2d15880 0 RetroArch [INFO] :: CHEEVOS video RAM: 0x2d35888 65536 RetroArch [INFO] :: Version of libretro API: 1 RetroArch [INFO] :: RetroArch [INFO] :: CHEEVOS RTC: 0x75e50d30 0 Compiled against API: 1 RetroArch [INFO] :: [Audio]: Set audio input rate to: 31987.82 Hz. RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/2xsal.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/2xScaleHQ.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/barrel-distortion.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/barrel-distortion_lanczos4.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/barrel-distortion_phosphor.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/barrel-distortion_snes.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/Brighter-with_Contrast.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/bsnes_gamma_ramp.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/crt-pi-curvature-vertical.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/crt-pi-curvature.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/crt-pi-vertical.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/crt-pi.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/gameboy-screen-grid.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/gameboy.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/gameboy2.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/hq2x&lcd3x.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/hq2x.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/hq2x2.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/hq2x_lcd3x.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/hq2x_phosphor.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/hq2xwaterpaint.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/hq2xwaterpaintscanline.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/hq4x.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/hq4x_lcd3x.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/nds.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/nedi.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/phosphor.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/snes.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/snes2.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/snes_hq2x.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/snes_hq2xwaterpaint.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/snes_hq2xwaterpainthicontrast.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/snes_hq2xwaterpaintscanline.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/snes_lcd3x.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/snes_phosphor.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/snes_scanline.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/snes_waterpaint.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/stock.glsl" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/super-2xsai.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/super-eagle.glslp" RetroArch [INFO] :: Found shader "/home/pi/.config/retroarch/shaders/xbr-lv1-noblend.glslp" RetroArch [INFO] :: [Video]: Video @ 897x672 RetroArch [INFO] :: [Video]: Starting threaded video driver ... RetroArch [INFO] :: [EGL] Falling back to eglGetDisplay RetroArch [INFO] :: [EGL]: EGL version: 1.4 RetroArch [INFO] :: [EGL]: Current context: 0x1. RetroArch [INFO] :: [GL]: Found GL context: videocore RetroArch [INFO] :: [GL]: Detecting screen resolution 1920x1080. RetroArch [INFO] :: [EGL]: eglSwapInterval(1) RetroArch [INFO] :: [EGL]: eglSwapInterval(1) RetroArch [INFO] :: [GL]: Vendor: Broadcom, Renderer: VideoCore IV HW. RetroArch [INFO] :: [GL]: Version: OpenGL ES 2.0. RetroArch [INFO] :: [GL]: Using resolution 1920x1080 RetroArch [INFO] :: [GL]: Default shader backend found: glsl. RetroArch [INFO] :: [Shader driver]: Using GLSL shader backend. RetroArch [WARN] :: [GL]: Stock GLSL shaders will be used. RetroArch [INFO] :: [GLSL]: Found GLSL vertex shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Found GLSL fragment shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Linking GLSL program. RetroArch [INFO] :: [GLSL]: Found GLSL vertex shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Found GLSL fragment shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Linking GLSL program. RetroArch [INFO] :: [GLSL]: Found GLSL vertex shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Found GLSL fragment shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Linking GLSL program. RetroArch [INFO] :: [GLSL]: Found GLSL vertex shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Found GLSL fragment shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Linking GLSL program. RetroArch [INFO] :: [GLSL]: Found GLSL vertex shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Found GLSL fragment shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Linking GLSL program. RetroArch [INFO] :: [GLSL]: Found GLSL vertex shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Found GLSL fragment shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Linking GLSL program. RetroArch [INFO] :: [GLSL]: Found GLSL vertex shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Found GLSL fragment shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Linking GLSL program. RetroArch [INFO] :: [GLSL]: Found GLSL vertex shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Found GLSL fragment shader. RetroArch [INFO] :: Shader log: Compiled RetroArch [INFO] :: [GLSL]: Linking GLSL program. RetroArch [INFO] :: [GL]: Using 4 textures. RetroArch [INFO] :: [GL]: Loaded 1 program(s). RetroArch [INFO] :: Querying EGL extension: KHR_image => exists RetroArch [INFO] :: [Font]: Using font rendering backend: freetype. RetroArch [INFO] :: [Video]: Graphics driver did not initialize an input driver. Attempting to pick a suitable driver. RetroArch [INFO] :: [udev] Adding device /dev/input/event0 as type ID_INPUT_KEYBOARD. RetroArch [INFO] :: [udev]: Plugged pad: Xbox 360 Wireless Receiver (1118:1817) on port #0. RetroArch [INFO] :: [udev]: Pad #0 (/dev/input/event2) supports force feedback. RetroArch [INFO] :: [udev]: Pad #0 (/dev/input/event2) supports 16 force feedback effects. RetroArch [INFO] :: [Autodetect]: 1 profiles found. RetroArch [INFO] :: [Autodetect]: selected configuration: /home/pi/.config/retroarch/autoconfig/Xbox 360 Wireless Receiver.cfg RetroArch [INFO] :: [Joypad]: Found joypad driver: "udev". RetroArch [WARN] :: [udev]: Full-screen pointer won't be available. RetroArch [INFO] :: ALSA: Using signed 16-bit format. RetroArch [INFO] :: ALSA: Period size: 384 frames RetroArch [INFO] :: ALSA: Buffer size: 1536 frames RetroArch [INFO] :: Custom timing given: FPS: 60.0988, Sample rate: 32040.5000 RetroArch [INFO] :: Detected viewport of 1440 x 1080 RetroArch [INFO] :: Recording to rtmp://live-jfk.
    /live_102953334_OpSc8wBkhEdG9gKikpa80ZYrNBHpG5 @ 1440x1080. (FB size: 2048x2048 pix_fmt: 1) [libx264 @ 0x2f9bfb0] using SAR=1/1 [libx264 @ 0x2f9bfb0] using cpu capabilities: ARMv6 NEON [libx264 @ 0x2f9bfb0] profile Main, level 4.2 [libx264 @ 0x2f9bfb0] 264 - core 152 r2851 ba24899 - H.264/MPEG-4 AVC codec - Copyleft 2003-2017 - http://www.videolan.org/x264.html - options: cabac=0 ref=1 deblock=0:1:1 analyse=0:0 me=dia subme=0 psy=1 psy_rd=0.40:0.00 mixed_ref=0 me_range=16 chroma_me=1 trellis=0 8x8dct=0 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=0 threads=2 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=2 b_pyramid=2 b_adapt=0 b_bias=0 direct=1 weightb=0 open_gop=0 weightp=0 keyint=120 keyint_min=60 scenecut=0 intra_refresh=0 rc_lookahead=0 rc=crf mbtree=0 crf=23.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 vbv_maxrate=512 vbv_bufsize=512 crf_max=0.0 nal_hrd=none filler=0 ip_ratio=1.40 pb_ratio=1.30 aq=0 RetroArch [ERROR] :: [FFmpeg]: Cannot find acodec libfdk_aac. RetroArch [ERROR] :: Failed to start recording. RetroArch [INFO] :: Loading history file: [/opt/retropie/configs/all/content_history.lpl]. RetroArch [INFO] :: Loading history file: [/opt/retropie/configs/all/content_music_history.lpl]. RetroArch [INFO] :: Loading history file: [/opt/retropie/configs/all/content_video_history.lpl]. RetroArch [INFO] :: Loading history file: [/opt/retropie/configs/all/content_image_history.lpl]. RetroArch [INFO] :: [Config]: Saved new config to "/opt/retropie/configs/snes/retroarch.cfg". RetroArch [INFO] :: Saved core options file to "/opt/retropie/configs/all/retroarch-core-options.cfg" RetroArch [INFO] :: Threaded video stats: Frames pushed: 5513, Frames dropped: 12. RetroArch [INFO] :: [Audio]: Average audio buffer saturation: 71.34 %, standard deviation (percentage points): 15.04 %. RetroArch [INFO] :: [Audio]: Amount of time spent close to underrun: 0.02 %. Close to blocking: 57.64 %. RetroArch [INFO] :: Removing temporary content file: /tmp/retroarch/Aladdin (USA).sfc. RetroArch [INFO] :: [Audio]: Average audio buffer saturation: 71.34 %, standard deviation (percentage points): 15.04 %. RetroArch [INFO] :: [Audio]: Amount of time spent close to underrun: 0.02 %. Close to blocking: 57.64 %. Sound buffer size: 128000 (32000 samples) Map_LoROMMap

    Any help would be sincerely appreciated.

    I am aware that it says libfdk_aac is said to be missing but I did follow the guide, rebooted and ran ldconfig as root.



  • I am aware that I was stupid and put the live code in there.... I since resetted it. For some reason I can't change what I wrote because AKISMET thinks I am spamming. Can't delete it because it keeps resetting my deletion timer.



  • Im trying to twitch with this guide: http://selsine.com/2016/10/17/how-to-live-stream-to-youtube-from-a-retropie/ but emulator run slow and very lag, turning the game unplayable. Anyone can run it smooth streaming via twitch?

    Using RPi3 and retroarch 4.2.



  • Hey anyone get this working on
    RetroPie 4.4
    RetroArch v1.7.1
    Raspbian Stretch?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.