Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Raspberry Pi Zero W refusing to connect to wifi after much fiddling.



  • I just purchased a brand new raspberry pi zero w version 1.1 to use with the retroflag gpi case as a portable emulator for on the bus or the train. So far I have assembled the device, used etcher to flash retropie 4.5.1 rpi1/zero onto the sd card and have gotten it to boot up into retropie. I've dropped in a blank file named ssh into the root directory along with a wpa_supplicant.conf containing the following code-

    country=US
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1

    network={
    ssid=[myssid]
    psk=[mypass]
    key_mgmt=WPA-PSK
    }

    -I also included a wifikeyfile.txt with the same ssid and pass to try and load via txt. Every time though I get an "unable to connect to network" error, sometimes including the networks name at the end and sometimes not. I'm using a comcast xfi router/modem combo with a wpa2-personal security mode. I've already tried splitting the dual banded connection into a separate 2.4 and 5ghz connection and tried only connecting to the 2.4ghz band. I've also tried changing the network name to all lowercase letters and numbers with no spaces, not sure if the password needs to be all lower as well, but so far nothing has indicated to me that the wifi shouldn't work. I can detect the network in the connection wizard and have tried entering the password with a bluetooth keyboard as well, so the bluetooth works, just can't make a connection using wifi. I really need to network up so I can load roms and updates so help would be appreciated.


  • Global Moderator

    @ZSlash Do you have any MAC filtering/access restrictions set up on the router ? Have you tried connecting it to another Wifi network ?
    The Zero should work with on the 2.4Ghz band, so using that SSID should be fine.



  • This post is deleted!


  • @ZSlash Do you have the name & password in quotes ? Also try removing the key_mgmt line, I had issues connecting when my file included that.



  • Wow, I feel super dumb. I spent too much time creating variables in c++ and nothing online told me the quotes were mandatory, just figured they were a placeholder.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.