Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Madcatz TES PS3 on retropie kinda working?



  • just recently got the arcadestick Madcatz TES PS3 version, i manage to make it work first time by doing this

    • going to retropie setup> manage package>driver
    • install customhidsony driver and mkarcadejoystick

    but when i shutdown my rpi3 the arcadestick doesnt do any inputs till i uninstall those drivers an hoping that they work again for some random reason when installing them again. i dont know if im missing something or am i doing something wrong i hope someone help me with this.

    i know the best thing is to replace the pcb, i ordered the zero delay pcb but it will arrive to my county in like 2 months... so wanted to know if there still some fix i can do meanwhile i recive the zero delay pcb thing, thank you for your time.


  • Global Moderator

    The mkarcadejoystick driver is for configuring a GPIO based gamepad, I don't think you need it installed - try to uninstall it and see if using just the customhidsony is enough.
    Please also add more info about your system, as detailed in https://retropie.org.uk/forum/topic/3/read-this-first.



  • i just did that but didnt work

    Pi Model or other hardware: rpi 3
    Power Supply used: rpi official one
    RetroPie Version Used 4.5.3
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: madcatz tes ps3 controller and keyboard
    Controller used: madcatz tes ps3
    How to replicate the problem: madcatz tes ps3 not making any inputs but it is recognized as PC USB Wired Stick 8838, i manage to make it work 2 times installing the drivers customhidsony and mkarcadejoystick (even when configuring inputs on retropie it recognize it as a madcatz controller when it worked instead of PC USB Wired Stick 8838 ) but now it does not seem to work


  • Global Moderator

    @alfredox123 said in Madcatz TES PS3 on retropie kinda working?:

    but now it does seem to work

    So.., does it work or not ? What's the point of this topic ?



  • now its working but i installed customhidsony and xarcade2jstick instead of mkarcadejosystick. gonna play for a while like this and give you an update if it still works after i shutdown de rpi



  • @mitu i just edited the post



  • @mitu the thing is that what i tested so far i need to uninstall and install those drivers to make it work sometimes after i shutdown the rpi, it seems pretty random thats why i say its kinda working


  • Global Moderator

    I see. As an advice, you don't need also the xarcadejoystick package, that's for another device. If it works with just customhidsonly, then you can leave it at that.



  • @mitu thats the other thing, if i install customhidsony only it doesnt work, my other theory is maybe i need to wait like a few mins to make it work with customhidsony only? cuz i just installed customhidsony and xarcade2jstick and it didnt work in the beginning but i leave it on for a while and now its working so maybe is that? i dont know how that drivers works


  • Global Moderator

    I don't think it's the driver, it's the gamepad that might not work reliably. If you un-plug it then plug-it back, does it work ?



  • ok i uninstalled xarcade2joystick and it still worked, i unplug and replug it and is not working again, im waiting a few mins to see if it register inputs again



  • after i unplug it and plug it again i couldnt manage to make it work again, tried wating for 30 min, tried uninstalling and installing again customhidsony, rebooting, shuting down, nothing. weird stuff



  • ive found this https://github.com/gr33k/MadCatz2Jstick its the exact same thing that my stick register as, gonna try it and tell if it works or not



  • i give up, theres no way to make this consistently work, best way is to replace the pcb or play on a ps3 which im doing right now



  • Besides of being a retrogaming-freak i am also a video-game collector in general.
    One section of my collection are Arcadesticks.
    So i tried various of my sticks with the Raspberry Pi:

    • Hanaho HotRod SE (using Adapter)
    • MadCatz StreetFighter 4 Tournament Stick (PS3)
    • SEGA Dreamcast ArcadeStick (using Adapter)
    • SNK NeoGeo Stick 2+ (PS3)
    • MortalKombat Tournament Stick (PS3)

    The only one that really worked great from the start by just plugging it in was the MortalKombat-Stick.
    Good luck that i like these boards very much (HAPP Parts) and have two of them ;)
    Alle the others did not run at all all or with issues (like yours with the MadCatz-Stick)



  • @sirhenrythe5th yeah it sucks but atleast ive got a borrowed ps3 and took advantage of ps3 end of year sale and got my friend usf4 for 3 bucks and borderlands 2 for 4 bucks meanwhile pcb arrives for the arcadestick :D



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.