Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Pi Model or other hardware: 4B 4GB
    Power Supply used: Apple 30W USB-C PSU
    RetroPie Version Used: 4.6
    Built From: retropie-buster-4.6-rpi4.img
    USB Devices connected: MADCATZ XBOX 360 Controller, Reddragon Mechanical Keyboard, Sandisk Cruzer 32GB
    Controller used: MADCATZ XBOX 360 Controller
    Error messages received: None
    Verbose log (if relevant): N/A
    Guide used: N/A, I know how to linux :)
    File: N/A
    Emulator: N/A

    Attachment of config files: This is a fresh installation, I really don't think this would be indicative of anything, literally 5 min into using OS, have not made any changes or transferred any ROMS.

    How to replicate the problem: Install OS using dd, setup controller, attempt to launch raspi-config or file manager in retropie configuration menu (Literally press A after controller setup).

    sudo dd bs=4M if=retropie-buster-4.6-rpi4.img of=/dev/sdb status=progress conv=fsync
    

    Standard Stuff.

    tl;dr
    After a fresh installation of the OS image (v4.6) from the website, no ROMS, nothing, launching file manager OR raspi-config from the retropie configuration menu just gives me a blank grey screen. oof.

    The PSU I'm using can supply more than enough power, I switched off of using a weaker one when I noticed the system was hanging and the green LED was quite faint. And, before you ask, yes, I have reflashed the SD card after switching PSU's, in case I corrupted the SD card. This is really weird.

    I also tried it with only the controller connected, disconnected my ethernet cable as well. Cooling is not an issue, I have an ICE tower mounted properly to the board with the included thermal pad.

    EDIT: I do realize Pi4 support is still in BETA, just thought I would throw this out there, because it does seem that some basic functionality was broken. I have used previous versions of retropie on the pi3.

  • Global Moderator

    @420noscope-exe Is your TV's resolution 4k ? I've seen it reported a few times in this combination. Set the resolution to 1080p and see if it works afterwards - 4k is a bit much for gaming on the Pi4.


  • @mitu It is definitely not on 4k, it is a 1080p 144Hz monitor (Acer). Connected via hdmi.

  • Global Moderator

    Can you run tvservice -s and tvservice -m DMT and post the output ?


  • @mitu I can't even get into the terminal by pressing F4, let me try connecting via SSH, I will get back to you on that.


  • @mitu

    pi@retropie:~ $ tvservice -s
    state 0xa [HDMI CUSTOM RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive
    pi@retropie:~ $ tvservice -m DMT
    Group DMT has 19 modes:
               mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive 
               mode 5: 640x480 @ 72Hz 4:3, clock:31MHz progressive 
               mode 6: 640x480 @ 75Hz 4:3, clock:31MHz progressive 
               mode 8: 800x600 @ 56Hz 4:3, clock:36MHz progressive 
               mode 9: 800x600 @ 60Hz 4:3, clock:40MHz progressive 
               mode 10: 800x600 @ 72Hz 4:3, clock:50MHz progressive 
               mode 11: 800x600 @ 75Hz 4:3, clock:49MHz progressive 
               mode 16: 1024x768 @ 60Hz 4:3, clock:65MHz progressive 
               mode 17: 1024x768 @ 70Hz 4:3, clock:75MHz progressive 
               mode 18: 1024x768 @ 75Hz 4:3, clock:78MHz progressive 
               mode 21: 1152x864 @ 75Hz 4:3, clock:108MHz progressive 
               mode 28: 1280x800 @ 60Hz 16:10, clock:83MHz progressive 
               mode 32: 1280x960 @ 60Hz 4:3, clock:108MHz progressive 
               mode 35: 1280x1024 @ 60Hz 5:4, clock:108MHz progressive 
               mode 36: 1280x1024 @ 75Hz 5:4, clock:135MHz progressive 
               mode 47: 1440x900 @ 60Hz 16:10, clock:106MHz progressive 
               mode 58: 1680x1050 @ 60Hz 16:10, clock:146MHz progressive 
               mode 82: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive 
               mode 85: 1280x720 @ 60Hz 16:9, clock:74MHz progressive 
    

    Screenshot from 2020-07-26 00-36-34.png

  • Global Moderator

    Your monitor doesn't specify any preferred resolution, that's a bit unusual. Try telling the Pi to ignore the monitor's EDID and set the resolution to 1080p via config.txt - see the options in https://www.raspberrypi.org/documentation/configuration/config-txt/video.md.


  • @mitu I added:

    hdmi_ignore_edid=0xa5000080
    

    to the config.txt in the boot partition, just above

    #config_hdmi_boost=4
    

    on line #35.

    That seems to do the trick. Excellent, thank you.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.