Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

PS3 Controller issues



  • Reading through the forum here I'm finding I might be better heading back to the Wireless xbox 360 controller and just hiding my Pi3 and the dongle. If anyone has any solution for the problems I'm having I might switch back at a later date.

    I switched to the PS3 controllers as the Pi3 has bluetooth. Unfortunately I've had the following issues with both the official PS3 controllers and Schwann(?) knockoffs.

    1. Controllers only work while wired: I've followed all instructions on the official forums and on various youtube videos. The controllers never sync. I've tried both the onboard bluetooth and using two different bluetooth dongles. I've installed the official PS3 drivers and the knockoff drivers.

    2. while controllers work while wired, Down on the D-pad functions as both down and "start". Every time I duck I also pause the game. Not sure why this is. I've been sure to map the correct buttons.

    3. Running the Retropie controller setup I can't click "Ok" at the end using the controller. This was weird. No issue with this on the xbox 360 wireless controller.

    4. I was forced to hard code the select and start buttons for (input_enable_hotkey_btn) and (input_exit_emulator_btn). The setup script wouldn't do this for me. Again no issue with this on my xbox 360 controller.

    Generally I've found bluetooth controllers to be a royal pain with the retropie in general. I've also tried my ouya controller (yes I bought one. It was my emulator console of choice before I found out about retropie) and I can't sync that either. I'm guessing this is more of an issue with the bluetooth stack in retropie. If anyone has a solution please feel free to respond. If you're having similar issues know you're not alone.



  • Try my approach combined with Luetzels' here:
    https://luetzels.raspiblog.com/?p=1870

    1. Install the patched Bluez from the blog (overwriting default raspbian bluez – do not uninstall it first, just overwrite).
    2. Then Shanwan sixad.
    3. Reboot, then its working like a boss..

    Try this first.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.