Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Static WIFI Ip address?



  • I've been going back and forth with different builds of my system, and it seems that the IP address of my PI3 has changed. I was having the darndest time trying to connect through SFTP and Putty to it before I discovered it had changed. I can't find anywhere through the basic setup scripts to assign a permanent static IP address. Is this just not possible through WIFI, or is there some other "secret" way by editing a file manually?



  • @hansolo77 You can check the IP adress always under ES-menu>Show IP
    Just for help in fixing thing which are no problems.

    AFAIK there is no way to set static IP adress for RetroPie out of the box.
    So we just do a bit of editing some files... eh?

    sudo nano /etc/network/interfaces

    # Ethernet
    auto eth0
    allow-hotplug eth0
    iface eth0 inet static
    address 192.168.1.2
    netmask 255.255.255.0
    gateway 192.168.1.1
    dns-nameservers 192.168.1.1
    

    Exchange Ethernet with WIFI adapter please!

    But there are other ways :)
    Change your hostname via raspi-config and name your builds like you want :)
    Use your router and set a fix IP for a given MAC adress.

    IMHO the hostname is the finest way instead of putty 192.168.1.2you write putty supermario - I prefer kitty rather then putty



  • If your router allows it, just set a static IP by MAC address. That's what I've done with my Pis.



  • Cool, thanks guys, at least you gave me some things to try.



  • I have been wanting to do this as well. I'm not a CLI expert, and have never tried setting up network interfaces before. I just do a little ssh and git, normally.

    I first tried the config here: https://github.com/retropie/retropie-setup/wiki/Wifi#static-ip

    Then I tried cyperghost's.

    Using cyperghost's, I can get the machine to come up with the IP addr I set (checked by using F4 to go to the CLI), but when I try to ssh or sftp in over wifi, it just times out.

    What might be the issue?

    Thanks!



  • I decided to go with changing the host name by using RetroPie's "raspconf" script off the ES main menu. In there is an option to change the hostname from "RetroPi" to something else. I called one "SegaPi" (for the mini Genesis hub) and "NESPI" (for the NES build). Then all I had to do was edit the entry in my SFTP program I was using to connect to the hostname rather than the IP address. Piece of cake that way.



  • @neobium Please use the @+name-sign or click on reply so the user you might want to talk is mentioned. If the WIFI IP is the one you've setted in the config and you can't connect to the Pie via WIFI then your security key (=WLAN Password, WPA passphrase.... ) might be wrong. Please check this first.

    To varify use CLI and use ping command
    ping your router first
    ping 192.168.1.1
    or via router hostname
    ping myrouter.ip
    ctrl+c stops ping command!

    or you can try wget command to download some files
    wget http://www.retropie.org.uk/
    you will get index.html from retropie

    Or are you behind a company proxy and want to play some games while in work? ;)
    Or is your subnet mask the right one? Is your router setted to only pass trusted devices?

    Are you able to optain a connection via DHCP? if yes then use the method @hansolo77 and myself explained. Change the hostname with raspi-config and you can use any IP you want .



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.