Please do not post a support request without first reading and following the advice in Configuration

  • Global Moderator


    You haven't made mention of which core you're trying to use, but currently, lr-nestopia is the only emulator in RetroPie to have NES zapper support. I can't remember if it's part of the default install, but you also need to make sure that you have the "NstDatabase.xml" file located at /opt/retropie/libretrocores/lr-nestopia/. If all this checks out and you're still having trouble, make sure that no other mouse devices are conflicting with the guns.

    After you get this going, you can also use your guns with lr-mame2003. RetroArch also supports these guns in SNES, Genesis/Megadrive, Master System, SegaCD and 32xCD through the use of lr-snes9x-next and lr-genesis-plus-gx. However, the mouse driver for these two cores is currently inoperable on the Pi. Whenever that is corrected, the Pi will have the best light gun support out of most any other retro-emulation solution besides a hacked Wii.

  • @mediamogul can a mouse work in lr-nestopia? I cant seem to get it to. I cant find a way to enable a light gu eithern. I have the database xml as well. Is there a way to enable a crosshair in lr-nestopia?

  • Hi Guys,

    I have read all your input thanks ! I just got a mail back from Eric at ArcadeGuns

    Hi Michel,

    I'm happy to help where I can. It's been a while since I've tried it on a
    raspberry Pi2. At that time, retro Pi didn't have a good modern mame
    available. So I used Advance Mame I believe which runs reasonably smooth.
    Something to keep in mind in Linux (Maybe just Mame in Linux) doesn't
    support Absolute Mouse correctly. I have yet to find anyone, including
    myself to get Linux to work with Absolute mouse correctly. Linux does
    however work perfectly with Joysticks. So I would recommend starting out
    setting your guns to Joystick Tracking mode. The games should just work
    after mapping the controls, but I couldn't get 2 guns to work correctly. I
    thought I had everything setup correctly, but the second gun just wouldn't
    work as a second gun in mame. You would probably be better off with a
    modern version of MAME, but raspberry pi will be very need
    better hardware to run newer versions of Mame typically..


    Is the game thinking the gun is a mouse? Is it tracking across the screen properly, but you can't use the trigger?

    No the best I got to now is to get one button to work :(

    I thought the best you could possibly do, with quite a bit of work, is to get the gun to mimic a mouse pointer in select games (i.e. ONLY games that have mouse support). They also need to support absolute? (believe that's the term) mouse coordinates or it won't work.

    Yes Eric mentions something about this

    I will keep on trying maybe we find a solution :)


    I am Using lr-nestopia but I did not do that:

    "NstDatabase.xml" file located at /opt/retropie/libretrocores/lr-nestopia/

    Will test out all the that you mentioned and give feedback


  • Global Moderator

    @edmaul69 said in Configuration:

    can a mouse work in lr-nestopia?

    I've got it working with relative coordinates right now, but it seems like my AimTrak guns were working the last time I tried them about a month ago.

    I cant find a way to enable a light gu eithern.

    I'm not able to check at the moment, but the setting is either located under the core options, core control options or possibly the standard input options for player 2.

    Is there a way to enable a crosshair in lr-nestopia?

    Nestopia checks against the "NstDatabase.xml" file to determine which game is light gun capable. Once it knows this, I believe the cross hairs are visible by default, but this setting might also reside in the core options.

  • Hi

    @mediamogul Can you share the cfg file of your gun ?

  • Global Moderator


    There's shouldn't really be a config file to speak of. RetroArch should just see it as a mouse device and use it accordingly. I need to uninstall the gun from my arcade cabinet and hook it up to my Pi again to confirm. Like I said, I tested it briefly about a month ago. The sticking point for me to get it to work was making sure that it was the only mouse device plugged in. Although it's not nearly as fun, I also have my analog gamepad mapped to play light gun games on the Pi, but that uses relative coordinates rather than absolute coordinates like the AimTrak guns.

  • 0_1479656976664_Screen Shot 2016-11-20 at 6.48.18 PM.png

    thats the file I need an example for:

  • Global Moderator

    I have yet to find anyone, including
    myself to get Linux to work with Absolute mouse correctly. Linux does
    however work perfectly with Joysticks.

    this isn't true or linux wouldn't support trackpads/touchscreens!

    mame2003 supports absolute coordinate mouse devices. see

  • Global Moderator


    thats the file I need an example for:

    It's possible we have different guns. The trigger on mine registers as a mouse click, which doesn't need to be mapped in most software that supports a mouse as a light gun device.

  • Yeah it's possible Mine is from but is recognized by retropie as a Ultimarc that's why I need to edit the config file but don't know how to do it... if I get a sample of a light gun config file maybe I can work it out.

    So anyone with a config file for a mouse that works or a light gun please share


  • Andy from Ultimarc says he is going to try and help out :)

  • Global Moderator


    That's great to hear! Please keep us updated.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.