Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Kodi 17 (Krypton) does not detect bluetooth ps3 gamepad



  • Hi,
    I upgraded my Kodi to the latest version available through the Retropie-setup script, and I seem to be unable to use my ps3 bluetooth controller to move around Kodi's menus. I tried the gamepad configuration tool in Kodi's menu, and it just doesn't detect any keypresses when it asks me to press the A, B, etc. keys.

    Right now, my tv cec-enabled remote works fine in Kodi, and the Ps3 controller is paired using the tool in retropie, working alright in emulationstation and all the emulators.

    I am using a Rpi 2, with a 2.5A power supply (never seen the rainbow square in the corner), using a retropie-setup script updated as of 12/02/2017 based on the Retropie 3.0 image, all of that on top of debian jessie. I use a bluetooth dongle to pair the controller, and I'm using a genuine Dualshock 3 gamepad.

    Is there a previous configuration step that I am unaware of? Is gamepad support in Kodi 17 enabled out of the box? Maybe only for wired gamepads?



  • I was having the same problem. The solution, as it turns out, is simple. Just run in the command line:

    sudo apt-get install kodi-peripheral-joystick

    Enjoy!



  • @Rascas

    Hmmm, another case like mine.
    These two guys had/have the same issue as I had.
    That cannot be a coincidence.
    Something during the update goes wrong or gets lost.
    Would it be better to uninstall the old Kodi first and then install Kodi 17? Or does it end up same?



  • @FlyingTomahawk I actually performed a fresh install of Kodi from the retropie-setup menu. The peripheral-joystick package might be missing from the installation script.



  • @RenanGreca

    Really? That is very interesting.
    Your statement confirms that not only updates are affected but also fresh installs.

    Kinda feel relieved now that I know it is not an issue on my setup only.


  • Banned

    @RenanGreca I suspect that may be the issue. I initially updated and the controller set up worked without a hitch. I had other problems which meant I had to purge Kodi and do a clean install of 17. The joystick support does not work now. There seemed to be a lot ot directories absent in the fresh install that were there when I updated on top of 16.



  • @RenanGreca said in Kodi 17 (Krypton) does not detect bluetooth ps3 gamepad:

    @FlyingTomahawk I actually performed a fresh install of Kodi from the retropie-setup menu. The peripheral-joystick package might be missing from the installation script.

    Peripheral-joystick isn't missing, but since this is new in Kodi 17, it was added only when Kodi 17 was pushed to bintray, some days ago.
    So you need to update RetroPie-Setup scripts before you make a new install or update to Kodi 17.


  • Banned

    @Rascas The peripheral-joystick package was there but the peripheral libraries were missing. In order to get it working I had to run sudo apt-get --reinstall install -y kodi-peripheral-joystick



  • @AlexMurphy kodi-peripheral-joystick package, is the libraries. If it is installed, it will show in Kodi, if not, it won't. Your problem seems to be something else than the OP and the second post.


  • Banned

    @Rascas Yeah, seems an odd issue. The Joystick support was there but the file path was missing or broken it would seem. A force reinstall has reset the path and Peripheral libraries now appear under the My Addons section.



  • Well, I wanted to confirm that just installing that missing package did the trick and the controller was recognized without needing to configure anything else in Kodi.

    Btw, I don't know if I can contribute to the discussion that it generated, but I installed Kodi after updating debian Wheezy to Jessie and updating the retropie-setup script, and that was the 12th of february.



  • @xwons That package is there to install if you have updated the RetroPie-Setup first:
    https://github.com/RetroPie/RetroPie-Setup/blob/master/scriptmodules/ports/kodi.sh#L45

    This is confirmed to be working at least with RetroPie 4.1 image + update RetroPie-Setup scripts.

    To check what is/was your problem with your installation, you have to provide your install log, for us to be able to help.



  • @Rascas The problem is solved. I just wanted to mention that despite updating the script before installing kodi (over an older version of kodi), the kodi-peripheral-joystick package had to be manually installed in my case. It's probably not an issue in newer installations, so it's alright.



  • Nice that you solved it. Next time, check this first:
    https://retropie.org.uk/forum/topic/3/read-this-first



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.