Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

pcsx-rearmed can't play enhanced resolution and no analog support (unsolved)



  • Hello there

    Did anyone managed to play psx games using Enhanced resolution (res. speed hack) on pcsx-rearmed core (non lr one) ? Because everytime I try to play game with those options turned on, it usually works fine within the menus but as soon as the real 3D graphic action kicks in the emulator crashes and send me back to EmulationStation.

    Also did anyone managed to activate analog sticks on pcsx-rearmed ? I've got the pcsx controller option set to analog, everything works correctly except the analog that doesn't answer. I suspect it is because I binded the joystick to "up,down,left,right" and this may corresponds to the DPad. But I don't see any options to set the analog axis (I tried to set X axis and Y axis value to any digits within "Analog Controls" options but it didn't change a thing. If it helps, here is my /opt/retropie/configs/psx/pcsx /pcsx.cfg : https://pastebin.com/q35icuwZ (with enhanced settings disabled for obvious testing reasons)

    Sorry for the long post, and thanks to anyone who managed to read it all. Even more thanks to those answering, no wrong answers, any tips, ideas, cookies are welcome.

    Specs : Raspberry Pi3
    Power Supply : Aukru 5V 3A
    RetroPie Version : 4.2.10,
    Built From : premade 4.1.0 SD Image
    USB Devices connected : Xbox 360 Controller, steam controller dongle, keyboard&mouse dongle
    Controller used : Xbox 360 Controller
    /dev/shm/runcommand.log : https://pastebin.com/LG7aXKrb
    /opt/retropie/configs/all/retroarch.cfg : https://pastebin.com/akTpmWa2
    Guide used : None
    Emulator : pcsx
    Logs ? Don't know where pcsx hide its logs
    How to replicate the problem:
    1/ Launch any psx games (mine are using .pbp formats)
    2/ Enable "Enhanced Resolution" and "Enhanced Resolution Speedhacks" by going into the options of the emulators (Esc key) -> Options -> [BIOS/Plugins] -> Configure built-in GPU plugin
    3/ Play any 3D section of the game, it should crash back to EmulationStation (tested with Driver, Colin Mcrae Rally 2.0, Crash Bandicoot 3, etc)



  • @aryetis are you going into retroarch gui, quick menu and option to change between standard and analog controllers? If you are and it still isnt working change all 8 controllers to match. Some games require analog and some games wont work with it on in the settings.



  • @edmaul69 I'm not using the lr core, therefore no retroarch gui.



  • @aryetis alrighty then. No clue then.



  • Bump ? Could someone at least point out to me location of pcsx log file so I can investigate please ?


  • Global Moderator

    the log is probably in /dev/shm/runcommand.log, after a crash.

    beyond that we can't really support unless you fill out ALL of the info here:
    https://retropie.org.uk/forum/topic/3/read-this-first



  • @dankcushions well it said fill relevant informations ... But okay I edited the first post. Please tell me if there is something missing.


  • Global Moderator

    @aryetis

    /dev/shm/runcommand.log ? Inexistant (already tried to search for it using : find / -name 'runcommand.log

    did you search for it after a PCSX crash, like I asked? BEFORE a reboot.

    it should definitely exist after an emulator is launched and exited.



  • @dankcushions My bad indeed forgot that /dev files get "deleted" on reboot. There you go first post edited. spoiler : it's SEG fault .... , and yes I tried to use HLE and bios files, got the same results :/


  • Global Moderator

    can you try with lr-pcsx? i know that at least is proven to work in this mode with no issue.

    if you get the same kind of issues i would guess maybe an unreliable power supply?



  • @dankcushions Well it used to work with lr-pcsx, even thought it was laggy sometimes (that's why I switched to non lr pcsx because it's faster) ... But for some reasons Ir controls are now broken, I'm mashing every button, combination of the controller and keyboard and I can't any answer, can't even go back to ES or get the retroarch gui

    And about the power supply, I highly doubt it because I did some slight overclocking and extensive testing to assure everything was stable.

    Thanks for answering tho.


  • Global Moderator

    @aryetis is your overclock still there? i'd get rid of ALL overclocking stuff if you've got stability issues.

    ut for some reasons Ir controls are now broken, I'm mashing every button, combination of the controller and keyboard and I can't any answer, can't even go back to ES or get the retroarch gui

    in just lr-pcsx or all lr-cores ?



  • @dankcushions I'd give no overclock a go, but honestly I didn't have a single crash in 1 hour of quake3 arena, super pi and MPrime ....Moreover the Seg fault is immediate , at the moment the loadings are over it crashes. It's not "random" like erros usualy due to bad OC . Anyways I'll test and get back with results.

    EDIT : without much surprises crashes happen even without any overclocking.

    And about the lr controls .... Indeed it seems to be lr related and not only lr-pcsx because it doesn't work either on nes, snes and probably all others. I probably have been pretty heavy handed when looking for those pcsx analog supports and deleted the wrong file.



  • Bump, adding /opt/retropie/configs/all/retroarch.cfg file to the first post ... I don't see anything wrong with it. Yet neither controller or keyboard work with lr-cores.
    EDIT : managed to get back controls on lr-cores by deleting /opt/retropie/configs/all/retroarch-joypads , disabling , enabling xboxdrv, remapping the controllers and lots of reboot

    On another note, no progress on getting enhanced resolution and analog support with pcsx-rearmed :/



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.