Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Emulationstation will not detect bluetooth controller after installing RetroPie 4.4



  • Hey guys,

    I have successfully paired two separate bluetooth controller to the Raspberry Pi and I am able to use it to navigate the menus in the Raspi-Config and Retropie Setup. However I have been unable to get emulationstation to detect the controllers when I go to configure inputs. I've also tested them both using jstest. (i.e. jstest --normal /dev/input/js0)

    While in emulationstation however, it continues to say "No gamepad's deteceted".

    Both these controllers worked in RetroPie 3.7 flawlessly without a wired controller attached.

    Any help anyone can offer would be very appreceated!


  • Global Moderator

    Please add more info about your system, as detailed in https://retropie.org.uk/forum/topic/3/read-this-first.



  • Thanks but I appear to have found the problem.

    It seems that udev was blocking the new controller. Creating a new udev rule seem to have corrected the issue.

    For anyone else having this problem, first identify the name of your controller. There are several ways you can do this but the simplest it probably to just look through the system logs. With the controller connected (either via bluetooth of hardwire) cat the messages log.

    sudo cat /var/log/messages

    You'll need to look through the messages for the right device name but if you just plugged in the controller or connected it via bluetooth it should be near the bottom. It may even be the last entry in the log.

    Apr 20 16:31:13 retropie kernel: [    8.528199] hid-generic 0005:1949:0402.0001: input,hidraw0: BLUETOOTH HID v1.1b Keyboard [Gamepad] on 00:1b:dc:0f:9d:ae
    

    Then create a new udev rule in the approprate location.

    sudo nano /etc/udev/rules.d/99-bluetooth.rules

    SUBSYSTEM=="input", ATTRS{name}=="Gamepad", MODE="0666", ENV{ID_INPUT_JOYSTICK}="1"
    

    Once done simple restart the system and it should now work in EmulationStation.

    I hope this is helpful for someone! If nothing else I'm sure I'll be back here one day trying to figure out what I need to do again. :-P



  • Had a similar problem with an old Ipega GamePad. Pair with BlueTooth with some re-connect issues, but worked with jstest and evtest.

    Adding the udev rule helped with emulationstation, but only the left joystick works in RetroArch.

    Running RetroPie 4.5.1 with updates. Any suggestions?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.