@mitu said in Pi3 B+ Stretch 3.5 audio out problems:

Seems similar to https://retropie.org.uk/forum/topic/17864/raspberry-pi-ridiculously-slow-when-splashscreen-service-is-enabled. Modify the /boot/config.txt and add

audio_pwm_mode=0

then restart and check if it fixes your problem.

yes! adding that line worked, thanks for the tip!