Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Launching Quake and it's extras (1 year anniversary release)



  • SCRIPTS ARE NOT NEEDED ANYMORE DUE FIX ON lr-tyrquake

    thx @psyke83


    Hello,

    I had some problems to run Quake and it's extras (dopa, hipnotic, rogue) with lr-tyrquake. I opened the wiki and made every step as written there but without success. I just was able to run Dopa and Quake full version. I think it's the symlinking to USB devices that makes this happen.

    So I stumpeld through the wiki got the reference of this thread here!.
    Unbelievable this was my first thread and I wrote it 07/09/2016 - so happy anniversary Mr. cyperghost.

    To make it short. I just coded a new script that now works! I tried to write it clean and fail safe.

    #1 Prerequistes

    1. You are using lr-tyrquake!
    2. Registered Version of QUAKE in v.1.06 or 1.08
    3. Mission Pack 1 - Scourge of Armagon aka hipnotic
    4. Mission Pack 2 - Dissolution of Eternity aka rogue
    5. Episode 5 - Dimension of the Past (20th years anniversary of QUAKE)
    6. Raspberry Pie with RetroPie and libretro-tyrquake installed
    7. Working zip! If zip isn't installed then type sudo apt install zip

    #2 Prerequistes

    The files pak0.pak and pak1.pak represents the main game (or base game) of Quake and are usually located in quake/id1/ folder

    Now, against the wiki recommendation copy all pak files from the extra packs to base files of quake.

    1. We rename hipnotic/pak0.pak to hipnotic.pak and copy to base files of Quake quake/id1/
    2. We Rename rogue/pak0.pak to rogue.pak and copy to base files of Quake quake/id1/
    3. We rename dopa/pak2.pak to dopa.pak and copy to base files of Quake quake/id1/

    Now we exchange the launching scripts from /home/pi/RetroPie/roms/ports with the one I provide on Github
    >> Please download from here

    If you exactly made the changes as I descriped here then no changes to the scripts must be taken. If some pathes/settings are vary from mine then please update them manually in each script. That's all!

    # Synopsis - Douple Check pathes and settings
    
    # path variable should always end without slash
    
    # pak1.pak loads full version of Quake
    # dopa.pak loads Episode 5
    # hipnotic.pak loads Mission Pack 1
    # rogue.pak loads Mission Pack 2
    #------------
    
    path="/home/pi/RetroPie/roms/ports/quake/id1"
    pakfile="hipnotic.pak"
    save="savegames_${pakfile%.*}.zip"
    

    How does it work!

    Well, I use the same trick as with the dopa-release. If you rename the extra packs ... maybe hipnotic.pakto pak2.pak then Hipnotic (the first Mission pack will be loaded) that does work with Dopa and Rogue. But the structure of savegames will be overwritten or is not useable. So I back them up in a seperate archive and reextract if needed.

    The system is really fail-safe

    • It checks presence of pak2.pak, so if a game session was unexpected broken (current drop, lightning stroke, gods hand) then script will stop with an error message.
      • So you never loose your gamedata!
    • Savegames of each extra pack (Hipnotic, Rogue, Dopa and of course Quake (Base Game)) will be saved and extracted if needed
      • So your savedata can be used as usual, you won't feel any difference
    • It checks the presence of the file that should be handeld (dopa pak for ex.). If the file is not present then the script stops with an error message of name of missing file.
    • You may also add fanmade or unoffcial level packs ....

    I tested several times and there was no failure.
    So I give the scripts to you - dear community - hope it will be usefull.
    So it's really by coincidence one year later! And by coincidence the same "thread" but now it should be resolved.

    @meleu
    Please feel free for tooltime if you want. I wasn't able to handle tar archives so I choosed zip with the disadvantage of getting a package loaded via apptitude

    >> Please download from here

    todays motto:

    old but not outdated



  • What about X-Men the Ravages of Apocalypse? :)



  • @BenMcLean
    That does not work with tyrquake :(
    I was able to see the intro sceen for less than a second and then tyrquake closed... What a pitty



  • @BenMcLean But Abyss of Pandemonium runs flawless. There is no need in running this script. You can also use it if you want.
    You extract it just to any folder ... and run pak0.pak. There is no need to copy around. If you want to use my scripts then use the version for Quake.
    Download Quake.sh and change pathes to Abyss of Pandemonium



  • X-Men the Ravages of Apocalypse works on darkplaces-quake I believe. I was able to run it on my setup. Although I'm not sure how one is supposed to get out of the hub area and into the game proper, and I couldn't figure out how to turn off antialiasing for the textures which this title really seems to need.



  • @cyperghost its cool that you made the script. But since i made seperate .sh files for each game and got it working with the folders, im curious, besides maybe easy to use, is there any advantage doing it your way?



  • @edmaul69 That is a really good question.... The reasons why I made these scripts are because I wasn't able to launch the addons even if I followed the documentated advices.

    I just was able to run Quake full version and Dopa (Episode 5)
    Hipnotic and Rogue were failing even by using .../quake/id1/hipnotic/pak0.pakand ...quake/id/rogue/pak0.pak.

    So I used the method used in Dopa (using the highest pak# in order) to load package. That worked flawless.

    Solution #1 would be... copy basefile of quake (pak0.pak and pak1.pak) and pak file of hipnotic androgue to pak2.pak and took them in seperate folders --> waste of storage space but savegames will be stored in seperate location.

    Solution #2 take my script it would save space but needs to compress savegames because save structure for all episodes in the series is equal s0.sav up to s11.sav and this would cause to load and even worse to override saved games created by ex. from Quake - Hipnoticin Quake - Rogue >> useless

    Symlinking was not possible so this script was my last resort :)
    Did you understand? In short:

    • It saves storage space on your SD/USB device
    • It makes savegames useable for the whole series because every savegame for each extra package is zipped in it's own archive and deflated before use.
    • Configuration is an easy setup by using variables
    • You can use it to run Dopa within Quake basefiles and save storage (usecase for every user)

    Be happy if it works for you in seperate folders. I wasn't able to use it that way - sadly... but as I wrote in my last sentence you can save same space to run Dopa that way :)

    @cyperghost its cool that you made the script.

    Thank you very much .... that is already my first bash-script I ever wrote. Don't worry I'm not a rookie in coding :D



  • @cyperghost i think i might have renamed dopa and hipnotic to pak 1 or 2 and stuck a copy of quake in each folder. Im not home to verify but i think it is what i had to do to get them to work. I will let you know in a few hours.



  • @edmaul69 That would be nice if you can check :)
    You might try out the scripts ... No worries they are fail safe but you need to install zip support first :)

    You can try at Dopa
    Rename pak2.pak to dopa.pak and install quake.shand dopa.sh from github and change pathes :)
    So you can use Dopaand Quakewithin one folder :)



  • @cyperghost so here are mine in each folder. only dopa is a duplicate pak0 and pak1 here is my layout.

    id folder
    pak0.pak
    pak1.pak
    dopa folder
    ---pak0.pak (duplicate)
    ---pak1.pak (duplicate)
    ---pak2.pak
    hipnotic folder
    ---pak0.pak
    rogue folder
    ---pak0.pak
    aos folder
    pak0.pak (no duplicates here)
    pak1.pak
    pak2.pak
    pak3.pak
    pak4.pak

    and here is what the configs look like

    Quake - Episode 5 - Dimension of the Past.sh

    #!/bin/bash
    "/opt/retropie/supplementary/runcommand/runcommand.sh" 0 _PORT_ "quake" "/home/pi/RetroPie/roms/ports/quake/id1/dopa/pak2.pak"
    

    Quake - Mission Pack 1 - Scourge of Armagon.sh

    #!/bin/bash
    "/opt/retropie/supplementary/runcommand/runcommand.sh" 0 _PORT_ "quake" "/home/pi/RetroPie/roms/ports/quake/id1/hipnotic/pak0.pak"
    

    Quake - Mission Pack 2 - Dissolution of Eternity.sh

    #!/bin/bash
    "/opt/retropie/supplementary/runcommand/runcommand.sh" 0 _PORT_ "quake" "/home/pi/RetroPie/roms/ports/quake/id1/rogue/pak0.pak"
    

    Quake - Mission Pack 3 - Abyss of Pandemonium .sh

    #!/bin/bash
    "/opt/retropie/supplementary/runcommand/runcommand.sh" 0 _PORT_ "quake" "/home/pi/RetroPie/roms/ports/quake/id1/aop/pak0.pak"
    


  • @cyperghost had to edit some stuff in last post



  • @edmaul69
    Thank you! Just for rechecking I post structure of files recommended in the wiki.
    The bash scripts you are using are the original ones and should work but as I said - for me it was not possible to start Hipnoticor Rogueas descriped in the wiki. You also see, that if you use own folders there is no problem with the save games.

    Original State as descriped in the wiki

    id1
    ├── pak0.pak
    ├── pak1.pak
    ├── s0.sav
    ├── s1.sav
    │
    ├── hipnotic
    │   ├── pak0.pak
    │   ├── s0.sav
    │   └── s1.sav
    │
    ├── rogue
    │   ├── pak0.pak
    │   ├── s0.sav
    │   └── s1.sav
    │
    └── dopa
        ├── pak0.pak (copy from id1)
        ├── pak1.pak (copy from id1)
        ├── pak2.pak
        ├── s0.sav
        └── s1.sav
    

    The state if you use my scripts, without launching a .sh file

    id1
    ├── pak0.pak
    ├── pak1.pak
    ├── dopa.pak
    ├── hipnotic.pak
    ├── rogue.pak
    ├── savegames_quake.zip
    ├── savegames_dopa.zip
    ├── savegames_rogue.zip
    └── savegames_hipnotic.zip
    

    State if you launch Quake.sh via my github script

    id1
    ├── pak0.pak
    ├── pak1.pak
    ├── dopa.pak
    ├── hipnotic.pak
    ├── rogue.pak
    ├── savegames_quake.zip
    │   ├── s0.sav
    │   └── s1.sav
    │
    ├── savegames_dopa.zip
    ├── savegames_rogue.zip
    └── savegames_hipnotic.zip
    

    State if you launch Quake - MP2 - Dissolution of Eternity (rogue).sh via my github script

    id1
    ├── pak0.pak
    ├── pak1.pak
    ├── dopa.pak
    ├── hipnotic.pak
    ├── pak2.pak
    ├── savegames_quake.zip
    ├── savegames_dopa.zip
    ├── savegames_rogue.zip
    │   ├── s0.sav
    │   └── s1.sav
    │
    └── savegames_hipnotic.zip
    


  • I've done a small update to v1.2: Filename of zipped savegames are now generated out of pakfilename

    id1.pak > savesgames_id1.zip
    rogue.pak > savesgames_rogue.zip
    IlikeRetroPie.pak > savesgames_IlikeRetroPie.zip



  • X-Men: The Ravages of Apocalypse should work. You just put PAK0.PAK, PAK2.PAK, PAK1.PAK, PAK4.PAK, PAK3.PAK and PROGS.DAT in your \\RETROPIE\roms\ports\quake\xmen folder and make a sh for it under ports which should say:

    #!/bin/bash
    "/opt/retropie/supplementary/runcommand/runcommand.sh" 0 _PORT_ "quake" "/home/pi/RetroPie/roms/ports/quake/xmen/pak0.pak"



  • @benmclean said in Launching Quake and it's extras (1 year anniversary release):

    X-Men: The Ravages of Apocalypse

    Which emulator do you use? lr-tyrquake? I can't get it up working with this. It would be really cool to get this running.

    Up to now my setup can run:

    • Quake (registered) -- using zip packer scripts
    • Quake MP1 - Hipnotic -- using zip packer scripts
    • Quake MP2- Rogue -- using zip packer scripts
    • Quake EP5 - Dopa -- using zip packer scripts
    • Quake Abyss of Pandemonium -- running in it's own folder
    • Quake Rally -- running in it's own folder

    Not working:

    • Quake - XMEN -- running it it's own folder (with pak0, pak1, pak2, pak3, pak4 and progs.dat)


  • Oh yeah, I forgot to check. I believe it uses darkplaces quake. I can double check after work. Oh and I was using a modified version from moddb. I don't know whether the original files work or not.

    BTW, it runs Quake Rally!?!? How does that work. I thought that mod required code modification?

    I'd really like to see Quake Matrix and SUPERQOT as well. :)



  • @benmclean
    Yes Quake Rally is smooth running.
    File structure is here

    RALLY
    |   CONFIG.CFG
    |   PAK0.PAK
    |   PAK1.PAK
    |   PROGS.DAT
    |   QRDEM1.DEM
    |   QRDEM2.DEM
    |   QRDEM3.DEM
    |   QRDOCS.TXT
    |   RALLY.CFG
    |   
    \---MAPS
            CULT.BSP
            QRALLY01.BSP
            QRALLY02.BSP
            QRALLY02.TXT
            QRALLY03.BSP
            QRDM01.BSP
            QRDM02.BSP
            QRDM02.TXT
            QRDM03.BSP
            QRDM03.TXT
            QRDM04.BSP
            START.BSP
    


  • X-Men: the Ravages of Apocalypse runs fine on darkplaces-quake and I used version 1.11 from moddb.

    I can't seem to get Quake Rally 1.2 to work. On darkplaces-quake, it adds the custom menu graphics but doesn't launch the quake rally maps. On tyrquake, it just instantly kicks you back to EmulationStation. What did your launch script look like?



  • @benmclean
    It's nothing special!

    Quake - Rally.sh

    #!/bin/bash
    path="/home/pi/RetroPie/roms/ports/quake/rally"
    
    #
    # Start the dance!
    #------------
    "/opt/retropie/supplementary/runcommand/runcommand.sh" 0 _PORT_ "quake" "${path}/pak0.pak"
    


  • @cyperghost i just realized that for the add on packs i am using tyrquake. I will try messing with setting them up in lr-tyrquake. Although i have mission pack 3 and 5th dimension running in tyrquake. Not sure if i will be able to get them running in lr-tyrquake.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.