Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

eduke32 freeze on mouse move



  • @mitu said in eduke32 freeze on mouse move:

    http://svn.eduke32.com/eduke32

    thank you so much!!! but it keeps going to the 6789 revision and resulting with the same error :(

    I also wanted to add that I found out what caused this error was after I had run an update to ALL installed packages from the setup menu.


  • Global Moderator

    @semper-5 said in eduke32 freeze on mouse move:

    I also wanted to add that I found out what caused this error was after I had run an update to ALL installed packages from the setup menu.

    Hm, that's the normal way to update, I don't see why it would affect eDuke32 when it's clear that building it from source is not working right now.
    As for the checkout command, I don't have a PI right now to test it, but it should work.



  • you sir are awesome once again!!

    my mistake on the edit of the eduke32.sh. it did eventually point to the right revision.
    and I tested it after updating ALL the packages that would normally cause the port to freeze. revision 6758 update from source did the trick :)

    thank you SO much. time to kick a$$ and chew bubblegum...


  • Global Moderator

    @semper-5 Are you playing with a gamepad only ? How's it working ?
    EDIT: don't forget to revert the changes to the eduke32.sh file, otherwise you'll get errors when updating the RP script.



  • @mitu no no, playing with keyboard and mouse. i don't think I could ever play a FPS properly with a gamepad lol

    so far so good. I'm going to start scripting up the expansions now.

    NOTE: I should add that when adding the expansions and overwriting the demo with full, eduke32 is very picky to which ones you get. I found a great pack of GRPs including some awesome ones I've never seen before (The Gate) but it would not accept it or the other addons. I HAD to use the GRPs and files from my Megaton Edition software.



  • Thanks, this worked for me too, the only problem is that with this version now the framerate is low :-/



  • I had this same problem and the solution worked for me, however the music is now somewhat buggy. When starting or switching a level the new track is muted, and I have to go into the options and disable/re-enable music to get the new track to play. Any potential fix for this would be nice, but it's a minor inconvenience at worst.



  • @finnbro Yes, I managed to solve the framerate issue and noticed the sound bug.
    I did the same trick and worked a couple of days ago.


  • administrators

    Now that the new release is out, I'll take a look at this. Maybe just roll back the version. Please feel free to open an issue on our GitHub.



  • Just want to add that the sound issue is still there in the most current update of the package: in the title screen and at the start of each level you only hear effects and you need to turn off / turn on music in the in-game settings which will then play the music fine - until you transition to a new level and the music is gone again.
    I would add this to Github as requested but I am unsure which repository would be the correct one?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.